Friday, October 2, 2009

What can happen if you have "\p" in your ORACLE_HOME

Hi, Today I have hit very strange error when I was trying to install Grid Control on Windows. This installation is split into two parts: installation of Grid Control and then patch to First part has been done without any problems but I have made a mistake. I have setup a beginning of all ORACLE_HOMEs to “e:\oracle\product\10.2.0\”. Grid Control creates itself 3 different ORACLE_HOME (one per DB, OMS and agent) using entered path as a prefix. A whole installation of has been performed without any problems and I have started an upgrade to During a configuration phase an OC4J deployment has been finished with error. I start to investigate and I was looked into OUI log file C:\Program Files\Oracle\Inventory\logs\installAction<...>.log

Can't find unicode character property definition via main->r or at unicode/Is/ line
oracle.ias.sysmgmt.repository.plugin.advanced.apache.parser.ParserException: parsing e:\oracle\product\10.2.0\oms10g\Apache\Apache\conf\ssl.conf:

Similar error is described in Metalink note 563468.1 but it is related to Oracle Application Server and OPatch utility. A cause of that error is a ORACLE_HOME value. Perl is interpreting the string "\p" in the Oracle home path as a regular expression. It is a little bit funny as Oracle is recommending an ORACLE HOME looking like ‘\oracle\product\’
I didn’t find any patch related to that error so I have just installed a Grid Control using a patch without “\p” string.


Anonymous said...

чтобы добавлять свои статьи, обязательно ли регистрироватся?